MSExchangeGuru.com

Learn Exchange the Guru way !!!

 

Error in Exchange 2010 OWA rule publishing on TMG

Post publishing OWA rule on a TMG server, clients get error “You could not be logged on to Forefront TMG. Make sure that your domain name, user name, and password are correct, and then try again.”

Information:

OWA rule is configured as per Microsoft guidelines with basic and form based with windows active directory authentication.

Exchange 2010 is also configured to use basic authentication

Issue:

OWA page is coming but Login is not working and also giving the following error:

“You could not be logged on to Forefront TMG. Make sure that your domain name, user name, and password are correct, and then try again.”

This error defines that there is some issue in login but you will try all the possible things to make it working.

Cause:

This will come because Threat Management Gateway server is part of workgroup which can’t authenticate users and in OWA publishing rule Users scope is selected to all authenticated users.

Resolution:

On OWA Publishing rule change the Users Tab scope from all authenticated user to all users.

Or

Make the TMG part of domain but this will not be recommend to make a firewall part of domain.

Prabhat Nigam

Team @MSExchangeGuru

11 Responses to “Error in Exchange 2010 OWA rule publishing on TMG”

  1. hari Says:

    I am using exchange 2010 beyond TMG Server. everything is working fine. owa is working fine from internet and internal.

    issue: One single user is unable to login to owa from external. He is getting TMG error.

    thanks

  2. Muthukumar P Says:

    Hari,

    Are there any restrictions on the OWA publishing rule for the users? Can you check if the specified user is a member of the group that has been granted access to OWA?

  3. Hari Says:

    No there are no restrictions for the users on the OWA Publishing rule.

  4. Muthukumar P Says:

    How about on user’s properties in EMC? Outlook Web App is enabled?

  5. hari Says:

    Outlook web app is enabled.

  6. Murali Says:

    Hi,

    It is working after changing to all users.

  7. Wizkid Says:

    How about Hari? Is it working after changing it to all users? If not then you might need to re-enable the protocols for the user from EMShell.

  8. net Says:

    hi
    I changed it to “all users” but it doesnot work again.it shows the forefront tmg auth page when I fill the username and password it shows owa page and I should fill it again.

  9. Wizkid Says:

    Hi Net,
    This article is for the particular error.
    “You could not be logged on to Forefront TMG. Make sure that your domain name, user name, and password are correct, and then try again.”

    If it is doing the redirection from ISA to OWA webpage and asking the password again then you need to fix the exchange configuration.

    Prabhat

  10. julia Says:

    I cannot access my e-mail and I feel very frustated

  11. Prabhat Nigam Says:

    @Julia
    Please send me the error. I will try to help you out.
    prabhat@msexchangeguru.com

Leave a Reply

ad

Categories

Archives