MSExchangeGuru.com

Learn Exchange the Guru way !!!

 

Exchange 2016 – Error in step 7 for exchange 2016 installation

One of the errors that you may face during installation of exchange 2016 that may hanged on the step 7 of 14: Mailbox role: Transport service with the following error:

”

The following error was generated when “$error.Clear();

if ( ($server -eq $null) -and ($RoleIsDatacenter -ne $true) )

{

Update-RmsSharedIdentity -ServerName $RoleNetBIOSName

}

” was run: “Microsoft.Exchange.Data.DataValidationException: Database is mandatory on UserMailbox.

at Microsoft.Exchange.Data.Directory.ADDataSession.Save(ADObject instanceToSave, IEnumerable`1 properties, Boolean bypassValidation)

at Microsoft.Exchange.Data.Directory.Recipient.ADRecipientObjectSession.Save(ADRecipient instanceToSave, String callerFilePath, Int32 callerFileLine, String memberName)

at Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity.Link()

at Microsoft.Exchange.Management.Deployment.UpdateRmsSharedIdentity.InternalProcessRecord()

at Microsoft.Exchange.Configuration.Tasks.Task.<ProcessRecord>b__91_1()

at Microsoft.Exchange.Configuration.Tasks.Task.InvokeRetryableFunc(String funcName, Action func, Boolean terminatePipelineIfFailed)”.

”

Based on this error message, issue occurs because some of the arbitration mailboxes don’t have mailbox database associated with them.

We could run the following command to confirm it:

”

Get-Mailbox -Arbitration | ft Name, Database –Auto

”

From the output, we could find the mailboxes that don’t have mailbox database assigned. In ADUC, delete the AD accounts, then re-run AD prepare to recreate the accounts. Then re-run Exchange setup program and check issue persists.

Ratish Nair

Microsoft MVP | Office Servers and Services

Team @MSExchangeGuru


Leave a Reply

Pages

Archives

Links

Categories

Recent Posts

Tags

Meta

MSExchangeGuru.com